package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(https?://\S*)|[[:punct:]]+`)
var str = `This is a URL: https://test.com/ThisIsAURL !`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}