using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?x)
\d+ # at least one digit
\. # a period
\s # a space
[^\d]++ # not a digit, 1 or more of them
(?=\d) # until we see a digit ahead
";
string input = @" 1. Which is your primary browser for development 2. Which of the following technologies have you made use of? 2. Which of the following technologies have you made use of? 3. How old ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}