import re
regex = re.compile((r"(?x) \n"
r"\d+ # at least one digit\n"
r"\. # a period\n"
r"\s # a space\n"
r"[^\d]++ # not a digit, 1 or more of them\n"
r"(?=\d) # until we see a digit ahead\n"))
test_str = " 1. Which is your primary browser for development 2. Which of the following technologies have you made use of? 2. Which of the following technologies have you made use of? 3. How old "
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")