$re = '/(?x)
\d+ # at least one digit
\. # a period
\s # a space
[^\d]++ # not a digit, 1 or more of them
(?=\d) # until we see a digit ahead
/';
$str = ' 1. Which is your primary browser for development 2. Which of the following technologies have you made use of? 2. Which of the following technologies have you made use of? 3. How old ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);