import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?!\\'[\\w\\s]*)foe(?![\\w\\s]*\\'))";
final String string = "var foe = 10;\n"
+ "foe = \"\";\n"
+ "dark_vador = 'bad guy'\n"
+ "foe = ' I\\'m your father, foe ! '\n"
+ "bar = thingy + foe";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}