$re = '/((?!\'[\w\s]*)foe(?![\w\s]*\'))/m';
$str = 'var foe = 10;
foe = "";
dark_vador = \'bad guy\'
foe = \' I\\\'m your father, foe ! \'
bar = thingy + foe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);