import re
regex = re.compile(r"((?!\'[\w\s]*)foe(?![\w\s]*\'))", flags=re.MULTILINE)
test_str = ("var foe = 10;\n"
"foe = \"\";\n"
"dark_vador = 'bad guy'\n"
"foe = ' I\\'m your father, foe ! '\n"
"bar = thingy + foe")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")