re = /((?!\'[\w\s]*)foe(?![\w\s]*\'))/m
str = 'var foe = 10;
foe = "";
dark_vador = \'bad guy\'
foe = \' I\\\'m your father, foe ! \'
bar = thingy + foe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end