$re = '/\d{3}.\d{3}.\d{3}-\d{2}/mi';
$str = 'CPF dos aprovados:
- 600.567.890-12
- 765.998.345-23
- 107.628.558-94
- 467.972.058-16
- 282.943.513-34
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);