// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\d{3}.\d{3}.\d{3}-\d{2}").unwrap();
let string = "CPF dos aprovados:
- 600.567.890-12
- 765.998.345-23
- 107.628.558-94
- 467.972.058-16
- 282.943.513-34
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}