import re
regex = re.compile(r"\d{3}.\d{3}.\d{3}-\d{2}", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("CPF dos aprovados:\n"
"- 600.567.890-12\n"
"- 765.998.345-23\n"
"- 107.628.558-94\n"
"- 467.972.058-16\n"
"- 282.943.513-34 \n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")