#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(0[1-9]|1[0-2])[\/\-](0[1-9]|1[\d]|2[\d]|3[01])[\/\-](\d{2,4})"
Local $sString = "31/12/2019" & @CRLF & _
"12/12/2029" & @CRLF & _
"12-19-19" & @CRLF & _
"19-23-2019" & @CRLF & _
"01-23-2018" & @CRLF & _
"15-89-2019" & @CRLF & _
"02-26-1974" & @CRLF & _
"02-50-1978" & @CRLF & _
"11/05/19"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)