package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z_\\\/.’'-]+(?: +[A-Za-z_\\\/.’'-]+)*$`)
var str = `Dinesh D'Soza
Name Surname\More 'names'
Name Surname\More 'names'
Name Surname\More 'names'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}