import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z_\\\\\\/.’'-]+(?: +[A-Za-z_\\\\\\/.’'-]+)*$";
final String string = "Dinesh D'Soza\n"
+ "Name Surname\\More 'names'\n"
+ "Name Surname\\More 'names' \n"
+ " Name Surname\\More 'names'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}