re = /^[a-zA-Z_\\\/.’'-]+(?: +[A-Za-z_\\\/.’'-]+)*$/m
str = 'Dinesh D\'Soza
Name Surname\\More \'names\'
Name Surname\\More \'names\'
Name Surname\\More \'names\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end