$re = '/^[a-zA-Z_\\\\\/.’\'-]+(?: +[A-Za-z_\\\\\/.’\'-]+)*$/m';
$str = 'Dinesh D\'Soza
Name Surname\\More \'names\'
Name Surname\\More \'names\'
Name Surname\\More \'names\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);