using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*\d)(?=.*[a-z])(?=.*[A-Z]).{8,16}";
string input = @"1aAbcdef
1aAAAAAA
a123AAAA
f345bC#4
f345bCdf";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}