re = /(?=.*\d)(?=.*[a-z])(?=.*[A-Z]).{8,16}/
str = '1aAbcdef
1aAAAAAA
a123AAAA
f345bC#4
f345bCdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end