#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Match)\n(\s+)\w+(?:\n\1\w+)+"
Local $sString = " Connection" & @CRLF & _
" Match" & @CRLF & _
" Fridolin" & @CRLF & _
" Marten" & @CRLF & _
" Connection" & @CRLF & _
" Inventory" & @CRLF & _
" Fill Up" & @CRLF & _
" Fill Up" & @CRLF & _
" Match" & @CRLF & _
" Peter" & @CRLF & _
" Marcus" & @CRLF & _
" Storage" & @CRLF & _
" Room 1" & @CRLF & _
" Room 2" & @CRLF & _
" Room 3" & @CRLF & _
" Match" & @CRLF & _
" Albert" & @CRLF & _
" Jona" & @CRLF & _
" Hans" & @CRLF & _
" List" & @CRLF & _
" Match" & @CRLF & _
" Peter" & @CRLF & _
" Marcus" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")