import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Match)\\n(\\s+)\\w+(?:\\n\\1\\w+)+";
final String string = " Connection\n"
+ " Match\n"
+ " Fridolin\n"
+ " Marten\n"
+ " Connection\n"
+ " Inventory\n"
+ " Fill Up\n"
+ " Fill Up\n"
+ " Match\n"
+ " Peter\n"
+ " Marcus\n"
+ " Storage\n"
+ " Room 1\n"
+ " Room 2\n"
+ " Room 3\n"
+ " Match\n"
+ " Albert\n"
+ " Jona\n"
+ " Hans\n"
+ " List\n"
+ " Match\n"
+ " Peter\n"
+ " Marcus\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}