const regex = /(?<=Match)\n(\s+)\w+(?:\n\1\w+)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Match)\\n(\\s+)\\w+(?:\\n\\1\\w+)+', 'gm')
const str = ` Connection
Match
Fridolin
Marten
Connection
Inventory
Fill Up
Fill Up
Match
Peter
Marcus
Storage
Room 1
Room 2
Room 3
Match
Albert
Jona
Hans
List
Match
Peter
Marcus
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}