import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\{\\s*_N\\s*\\(\\s*'([^\\\\']*(?:\\\\.[^\\\\']*)*)'\\s*,\\s*'([^\\\\']*(?:\\\\.[^\\\\']*)*)'\\s*(.*?)\\}>";
final String string = "<{_N( 'some_domain_id' , 'this \\'can\\' be an arbitary string',{'a':'b','c':'d'})}>\n"
+ "<{_N( 'some_domain_id' , 'this can ( be an arbitary ) string',{'a':'b','c':'d'})}>\n"
+ "<{_N( 'some_domain_id' , 'this can be an arbitary string' {'a':'b','c':'d'})|e('modifier')}>\n"
+ "<{_N( 'some_domain_id' , 'this can be an arbitary string')|e('modifier')}>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}