$re = '/<{\s*_N\s*\(\s*\'([^\\\\\']*(?:\\\\.[^\\\\\']*)*)\'\s*,\s*\'([^\\\\\']*(?:\\\\.[^\\\\\']*)*)\'\s*(.*?)}>/';
$str = '<{_N( \'some_domain_id\' , \'this \\\'can\\\' be an arbitary string\',{\'a\':\'b\',\'c\':\'d\'})}>
<{_N( \'some_domain_id\' , \'this can ( be an arbitary ) string\',{\'a\':\'b\',\'c\':\'d\'})}>
<{_N( \'some_domain_id\' , \'this can be an arbitary string\' {\'a\':\'b\',\'c\':\'d\'})|e(\'modifier\')}>
<{_N( \'some_domain_id\' , \'this can be an arbitary string\')|e(\'modifier\')}>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);