re = /<{\s*_N\s*\(\s*'([^\\']*(?:\\.[^\\']*)*)'\s*,\s*'([^\\']*(?:\\.[^\\']*)*)'\s*(.*?)}>/
str = '<{_N( \'some_domain_id\' , \'this \\\'can\\\' be an arbitary string\',{\'a\':\'b\',\'c\':\'d\'})}>
<{_N( \'some_domain_id\' , \'this can ( be an arbitary ) string\',{\'a\':\'b\',\'c\':\'d\'})}>
<{_N( \'some_domain_id\' , \'this can be an arbitary string\' {\'a\':\'b\',\'c\':\'d\'})|e(\'modifier\')}>
<{_N( \'some_domain_id\' , \'this can be an arbitary string\')|e(\'modifier\')}>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end