import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)(?=outputtable).*";
final String string = "rfoutputtablep7q10000t20000c100\n"
+ "rfoutputtablep7q1000t20000c100\n"
+ "svmLinear2outputtablep7q20000t20000c100\n"
+ "svmLinear2outputtablep7q5000t20000c100";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}