re = /(\w+)(?=outputtable).*/m
str = 'rfoutputtablep7q10000t20000c100
rfoutputtablep7q1000t20000c100
svmLinear2outputtablep7q20000t20000c100
svmLinear2outputtablep7q5000t20000c100'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result