const regex = /(\w+)(?=outputtable).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)(?=outputtable).*', 'gm')
const str = `rfoutputtablep7q10000t20000c100
rfoutputtablep7q1000t20000c100
svmLinear2outputtablep7q20000t20000c100
svmLinear2outputtablep7q5000t20000c100`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);