#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)&sql\(fetch \w+\s(?!into).*\)"
Local $sString = "&sql(fetch cursorName into :family, ,:name, :birthday, :sex)" & @CRLF & _
"&sql(fetch cursorName :family, ,:name, :birthday, :sex)" & @CRLF & _
"&sql(fetch cursorName :into, ,:name, :birthday, :sex )" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")