import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "&sql\\(fetch \\w+\\s(?!into).*\\)";
final String string = "&sql(fetch cursorName into :family, ,:name, :birthday, :sex)\n"
+ "&sql(fetch cursorName :family, ,:name, :birthday, :sex)\n"
+ "&sql(fetch cursorName :into, ,:name, :birthday, :sex )\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}