$re = '/&sql\(fetch \w+\s(?!into).*\)/m';
$str = '&sql(fetch cursorName into :family, ,:name, :birthday, :sex)
&sql(fetch cursorName :family, ,:name, :birthday, :sex)
&sql(fetch cursorName :into, ,:name, :birthday, :sex )
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);