re = /&sql\(fetch \w+\s(?!into).*\)/m
str = '&sql(fetch cursorName into :family, ,:name, :birthday, :sex)
&sql(fetch cursorName :family, ,:name, :birthday, :sex)
&sql(fetch cursorName :into, ,:name, :birthday, :sex )
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end