using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^poliamb/(?P<m_path>\w+(?:-\w+)*)/?$";
string input = @"poliamb/test1
poliamb/test1-other
poliamb/test1/
poliamb/test1-other/
poliamb/test1---other
poliamb/test1---other/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}