import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^poliamb/(?P<m_path>\\w+(?:-\\w+)*)/?$";
final String string = "poliamb/test1\n"
+ "poliamb/test1-other\n"
+ "poliamb/test1/\n"
+ "poliamb/test1-other/\n\n"
+ "poliamb/test1---other\n"
+ "poliamb/test1---other/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}