package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^poliamb/(?P<m_path>\w+(?:-\w+)*)/?$`)
var str = `poliamb/test1
poliamb/test1-other
poliamb/test1/
poliamb/test1-other/
poliamb/test1---other
poliamb/test1---other/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}