using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\h*(<[^>]*>|\S+)\h+(.*?)\h+(<[^>]*>|\S+)\h*$";
string input = @"ewd1 serpent 0 n ne o u w nw swamp
bats 0 n ne o u w nw swamp
undead 0 n ne o u w nw swamp
n river2 n ne o u
1002 e d
n <ewd8 ewd9 ewd2> se
n ewd9 s
n ewd2 sw
n rough w nw swamp
ewd2 serpent 0 w nw n swamp
bats 0 w nw n swamp
undead 0 w nw n swamp
n rough w nw n swamp
n <ewd1 ewd9 ewd10> ne o
n ewd9 e
n ewd10 se
n ewd4 s
n ewd3 sw";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}