// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\h*(<[^>]*>|\S+)\h+(.*?)\h+(<[^>]*>|\S+)\h*$").unwrap();
let string = "ewd1 serpent 0 n ne o u w nw swamp
bats 0 n ne o u w nw swamp
undead 0 n ne o u w nw swamp
n river2 n ne o u
1002 e d
n <ewd8 ewd9 ewd2> se
n ewd9 s
n ewd2 sw
n rough w nw swamp
ewd2 serpent 0 w nw n swamp
bats 0 w nw n swamp
undead 0 w nw n swamp
n rough w nw n swamp
n <ewd1 ewd9 ewd10> ne o
n ewd9 e
n ewd10 se
n ewd4 s
n ewd3 sw";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}