import Foundation
let pattern = #"^\h*(<[^>]*>|\S+)\h+(.*?)\h+(<[^>]*>|\S+)\h*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ewd1 serpent 0 n ne o u w nw swamp
bats 0 n ne o u w nw swamp
undead 0 n ne o u w nw swamp
n river2 n ne o u
1002 e d
n <ewd8 ewd9 ewd2> se
n ewd9 s
n ewd2 sw
n rough w nw swamp
ewd2 serpent 0 w nw n swamp
bats 0 w nw n swamp
undead 0 w nw n swamp
n rough w nw n swamp
n <ewd1 ewd9 ewd10> ne o
n ewd9 e
n ewd10 se
n ewd4 s
n ewd3 sw
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)