import re
regex = re.compile(r"^\h*(<[^>]*>|\S+)\h+(.*?)\h+(<[^>]*>|\S+)\h*$", flags=re.MULTILINE)
test_str = ("ewd1 serpent 0 n ne o u w nw swamp\n"
" bats 0 n ne o u w nw swamp\n"
" undead 0 n ne o u w nw swamp\n"
" n river2 n ne o u\n"
" 1002 e d\n"
" n <ewd8 ewd9 ewd2> se\n"
" n ewd9 s\n"
" n ewd2 sw\n"
" n rough w nw swamp\n"
"ewd2 serpent 0 w nw n swamp\n"
" bats 0 w nw n swamp\n"
" undead 0 w nw n swamp\n"
" n rough w nw n swamp\n"
" n <ewd1 ewd9 ewd10> ne o\n"
" n ewd9 e\n"
" n ewd10 se\n"
" n ewd4 s\n"
" n ewd3 sw")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")