use strict;
my $str = '<?=(function($n,$snake){foreach(array_chunk(range(1,$n*$n),$n)as$i=>$a){if($i%2)$a=array_reverse($a);echo"\\n",join(\'\',array_map(function($e){return(sprintf("%3d",$e));},$a));}})($argv[1],\'-=-=-=-=-=-=-=-=-=-=-=-=-=-o~\')?>';
my $regex = qr~^[^\s/\#6]{221}$~p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}