re = /^[^\s\/\#6]{221}$/
str = '<?=(function($n,$snake){foreach(array_chunk(range(1,$n*$n),$n)as$i=>$a){if($i%2)$a=array_reverse($a);echo"\\n",join(\'\',array_map(function($e){return(sprintf("%3d",$e));},$a));}})($argv[1],\'-=-=-=-=-=-=-=-=-=-=-=-=-=-o~\')?>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end