$re = '~^[^\s/\#6]{221}$~';
$str = '<?=(function($n,$snake){foreach(array_chunk(range(1,$n*$n),$n)as$i=>$a){if($i%2)$a=array_reverse($a);echo"\\n",join(\'\',array_map(function($e){return(sprintf("%3d",$e));},$a));}})($argv[1],\'-=-=-=-=-=-=-=-=-=-=-=-=-=-o~\')?>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);