import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<(?P<opener>code|pre)>.*?<\\/(?P=opener)>)?(?!<(code|pre)>)*(\\d+)";
final String string = "bla bla !1234 abcd <pre> every occurrence here should be ignored !12345 but it is not </pre> here should be captured !54321 but <code><pre> here it should be again ignored !76453 </pre></code> and here again captured !123456";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}