use strict;
my $str = 'bla bla !1234 abcd <pre> every occurrence here should be ignored !12345 but it is not </pre> here should be captured !54321 but <code><pre> here it should be again ignored !76453 </pre></code> and here again captured !123456';
my $regex = qr/(?:<(?P<opener>code|pre)>.*?<\/(?P=opener)>)?(?!<(code|pre)>)*(\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}