re = /(?:<(?P<opener>code|pre)>.*?<\/(?P=opener)>)?(?!<(code|pre)>)*(\d+)/m
str = 'bla bla !1234 abcd <pre> every occurrence here should be ignored !12345 but it is not </pre> here should be captured !54321 but <code><pre> here it should be again ignored !76453 </pre></code> and here again captured !123456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end