const regex = new RegExp('(?:<(?P<opener>code|pre)>.*?<\\/(?P=opener)>)?(?!<(code|pre)>)*(\\d+)', 'gm')
const str = `bla bla !1234 abcd <pre> every occurrence here should be ignored !12345 but it is not </pre> here should be captured !54321 but <code><pre> here it should be again ignored !76453 </pre></code> and here again captured !123456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}