using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+(?<Response_Time>[^ ]+)\sms";
string input = @"{""kubernetes"":{""container_name"":""sign-template-services"",""namespace_name"":""merch-ps-signs-stress-1"",""pod_name"":""sign-template-services-14-chfbn""},""message"":""::ffff:100.65.19.1 - - [05-Mar-2020 09:58:48 CST] \""GET /health HTTP/1.1\"" 200 30 - 7.807 ms\n"",""hostname"":""ocp-usc1-lle-b-app-f-g3q9.c.kohls-openshift-lle.internal"",""@timestamp"":""2020-03-05T15:58:48.231999+00:00"",""cluster_name"":""ocp.gcpusc1-b.lle.xpaas""}
{""kubernetes"":{""container_name"":""sign-template-services"",""namespace_name"":""merch-ps-signs-ci"",""pod_name"":""sign-template-services-39-gb69d""},""message"":""::ffff:100.109.92.1 - - [05-Mar-2020 09:57:31 CST] \""GET /health HTTP/1.1\"" 200 30 - 33.245 ms\n"",""hostname"":""ocp-usc1-lle-c-app-f-7ml9.c.kohls-openshift-lle.internal"",""@timestamp"":""2020-03-05T15:57:31.808739+00:00"",""cluster_name"":""ocp.gcpusc1-c.lle.xpaas""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}