// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s+(?<Response_Time>[^ ]+)\sms").unwrap();
let string = "{\"kubernetes\":{\"container_name\":\"sign-template-services\",\"namespace_name\":\"merch-ps-signs-stress-1\",\"pod_name\":\"sign-template-services-14-chfbn\"},\"message\":\"::ffff:100.65.19.1 - - [05-Mar-2020 09:58:48 CST] \\\"GET /health HTTP/1.1\\\" 200 30 - 7.807 ms\\n\",\"hostname\":\"ocp-usc1-lle-b-app-f-g3q9.c.kohls-openshift-lle.internal\",\"@timestamp\":\"2020-03-05T15:58:48.231999+00:00\",\"cluster_name\":\"ocp.gcpusc1-b.lle.xpaas\"}
{\"kubernetes\":{\"container_name\":\"sign-template-services\",\"namespace_name\":\"merch-ps-signs-ci\",\"pod_name\":\"sign-template-services-39-gb69d\"},\"message\":\"::ffff:100.109.92.1 - - [05-Mar-2020 09:57:31 CST] \\\"GET /health HTTP/1.1\\\" 200 30 - 33.245 ms\\n\",\"hostname\":\"ocp-usc1-lle-c-app-f-7ml9.c.kohls-openshift-lle.internal\",\"@timestamp\":\"2020-03-05T15:57:31.808739+00:00\",\"cluster_name\":\"ocp.gcpusc1-c.lle.xpaas\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}