import re
regex = re.compile(r"\s+(?<Response_Time>[^ ]+)\sms", flags=re.MULTILINE)
test_str = ("{\"kubernetes\":{\"container_name\":\"sign-template-services\",\"namespace_name\":\"merch-ps-signs-stress-1\",\"pod_name\":\"sign-template-services-14-chfbn\"},\"message\":\"::ffff:100.65.19.1 - - [05-Mar-2020 09:58:48 CST] \\\"GET /health HTTP/1.1\\\" 200 30 - 7.807 ms\\n\",\"hostname\":\"ocp-usc1-lle-b-app-f-g3q9.c.kohls-openshift-lle.internal\",\"@timestamp\":\"2020-03-05T15:58:48.231999+00:00\",\"cluster_name\":\"ocp.gcpusc1-b.lle.xpaas\"}\n\n"
"{\"kubernetes\":{\"container_name\":\"sign-template-services\",\"namespace_name\":\"merch-ps-signs-ci\",\"pod_name\":\"sign-template-services-39-gb69d\"},\"message\":\"::ffff:100.109.92.1 - - [05-Mar-2020 09:57:31 CST] \\\"GET /health HTTP/1.1\\\" 200 30 - 33.245 ms\\n\",\"hostname\":\"ocp-usc1-lle-c-app-f-7ml9.c.kohls-openshift-lle.internal\",\"@timestamp\":\"2020-03-05T15:57:31.808739+00:00\",\"cluster_name\":\"ocp.gcpusc1-c.lle.xpaas\"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")