import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+(?<Response_Time>[^ ]+)\\sms";
final String string = "{\"kubernetes\":{\"container_name\":\"sign-template-services\",\"namespace_name\":\"merch-ps-signs-stress-1\",\"pod_name\":\"sign-template-services-14-chfbn\"},\"message\":\"::ffff:100.65.19.1 - - [05-Mar-2020 09:58:48 CST] \\\"GET /health HTTP/1.1\\\" 200 30 - 7.807 ms\\n\",\"hostname\":\"ocp-usc1-lle-b-app-f-g3q9.c.kohls-openshift-lle.internal\",\"@timestamp\":\"2020-03-05T15:58:48.231999+00:00\",\"cluster_name\":\"ocp.gcpusc1-b.lle.xpaas\"}\n\n"
+ "{\"kubernetes\":{\"container_name\":\"sign-template-services\",\"namespace_name\":\"merch-ps-signs-ci\",\"pod_name\":\"sign-template-services-39-gb69d\"},\"message\":\"::ffff:100.109.92.1 - - [05-Mar-2020 09:57:31 CST] \\\"GET /health HTTP/1.1\\\" 200 30 - 33.245 ms\\n\",\"hostname\":\"ocp-usc1-lle-c-app-f-7ml9.c.kohls-openshift-lle.internal\",\"@timestamp\":\"2020-03-05T15:57:31.808739+00:00\",\"cluster_name\":\"ocp.gcpusc1-c.lle.xpaas\"}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}