#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[-+ ]?[178]?[ ]?\d[ ]?\d[ ]?\d[ ]?\d[ ]?\d[ ]?\d[ ]?"
Local $sString = "'Собственник. Продаётся НОВАЯ 5-х комнатная квартира только после ремонта, всё новое в идеальном состоянии. Оплата только наличными, можно валютой. Отдельное место на подземном паркинге, автономное отопление, Стены – наружные, крупноформатный рядовой поризиванный камень. Внутренние перегородки — камень двойной поризованный. 5B0HИTЬ 76 OO 26. Или на Baйбep +7931ll78О93'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")